6 Hours after reset , No more flickering , now i want it to happen ¬



  • Followed Surface Pro Device from the first one , used to have a laptop which was in a working condition , so by the time i got Surface , it was a Pro 4 at the end of November 2015 .
    Towards November 2016 , was faced with an issue where it would not turn on (forgot the exact details) got it sent to MSFT and got a refurbished device back.

    Immidiately noticed flickering issues every now and den ( was rare but happened always , usually power on and off which would turn display on and off would kinda fix it ) , last few weeks i had this horizontal flicker at the bottom of the screen , which would display elements from the top of the screen .
    Again moving mouse would make it go away for few minutes(atleast thats what i think made it go away ) , but last 3 days nothing made it go away .
    Yesterday whole screen started flickering , double projection etc etc.
    with the horizontal flicker at the bottom of the screen which displayed the top of the screen.

    It started out with now and den over the day , and towards the end refused to go away despite restarts , figured i would do a reset . During and after the reset it did not go away ( you can watch it in the video linked ) , very upset and frustrated turned it off , Slept the night , woke up called up microsoft from Dubai , turns out they dont really have a support system for helping out here ( idk how they did it last time ) , some how ended up on phone with some one , reported my issue and after 20 mins of talking through , they helped me with the plan.

    When i visit india , ship my device through FEDEX(free through label) , they will have a look at my device and send me a certified refurbished device that works.

    Now the problem is after that call , turned on my device and for the first time in weeks , i dont see flicker(even the horizontal one at the bottom ) , now am bummed . If its permanently fixed imma be happy , but if its temporary its going to be annoying to ship it to MSFT and same device returned with a " we did not experience the reported problem"

    During reset
    https://www.youtube.com/watch?v=PhNFdbRf7ws

    After Reset
    https://www.youtube.com/watch?v=Tz9JFibF6Ho

    EDIT: Experienced a small horizontal flicker for few seconds just now towards the end of this post (while writing it ) , feel like a scumbag now hoping for it to happen.

    I love my devices , i bond with em emotionally (not to a retarded level) , so hoping for it to flicker so i can get it replaced with a good device makes me feel bad.


 

Looks like your connection to Flickergate Forum was lost, please wait while we try to reconnect.