An actual software solution!



  • I've had my Pro 4 since 2015 (Not eligible for free replacement)
    Screen scramble started 2016
    I noticed it only happened with a static image.
    Reading that someone had been using an open task manager which solved the problem (due to it refreshing the screen) I came up with the "enable seconds on the clock" solution and posted it as a comment in a forum somewhere (I forget which forum, but it seems it has been adopted quite a bit since then).
    However since then it has deteriorated more and now screen scramble occurs even with the seconds on the clock enabled.
    Forcing me to try find a real fix:

    I've discovered if I run my screen at a slower refresh rate, the scramble stops!
    However the Intel graphics drivers lock the Surface screen to 60hz for all resolutions, you have to create custom resolutions, which you can't do with Intel's tools, or Windows.

    You need an Intel driver which enables EDID overrides.
    I have an i7-6650U, the latest drivers from Intel.com seem to work. I am using 26.20.100.7212
    Download, Install and reboot.

    Next you will need a tool to create custom resolutions:
    https://www.monitortests.com/forum/Thread-Custom-Resolution-Utility-CRU
    When using this tool, you will have 1 resolution in the detailed resolutions slots.
    2736x1824 @ 60Hz
    Select it and click edit, then click copy, but don't change this one, just close it.
    (You'll need it if you somehow create an unsupported rate)
    Now click Add, click paste, then change ONLY the refresh rate, from 60 to 50.
    (I have tested, the screen could run down to 40Hz, but not 30Hz)
    Click OK, close CRU and reboot.

    Go into display settings, scroll down to Multiple Displays, Click Advanced Display Settings.
    Click Display adapter properties for Display 1.
    Choose the Monitor tab and change the refresh rate to 50 Hertz.
    Click OK.

    This has worked for me, let me know if it works for you.



  • @kev said in An actual software solution!:

    enable seconds on the clock

    Hi Kev Im living in Sweden and my Surface start Flickering for months ago.
    I have tried everything until one month ago ive tried enable seconds on the clock
    Since then my Surface have worked great,no flickering at all



  • This post is deleted!


  • @j-j-lehto The "enable seconds solution" worked for some time for me too, however eventually it does start scrambling.
    Hardware deteriorated with use I think.



  • @kev
    Thanks Kev
    Mine had been evolving (or devolving) at first, it would fix with the movement of the mouse, then I added the seconds to the clock and that fixed it for a while, then I made the USB fan blowing in the back and that worked for another while, now the fan sometimes helps and others don't. So I waited until the condition got really bad (barely could read the instructions) to try your recommended fix.

    I tried 50Hz and that made it a bit better, then 45 and it got almost OK then I went to 40 and for some reason 45 was better.

    So I'm thinking this fix plus the fan and new and better thermal paste in the not so distant future might do the final trick.

    Thanks again



  • @kev
    I can pinpoint to when my surface started misbehaving, that day I binged watch Netflix for hours and connected the surface to my TV to watch on the big screen, in order to keep it safe, I laid it flat on the aluminum side; when I picked it up it was really hot, hotter than at any time I could remember, the next day I started having the slight flicker at first and it has been progressively deteriorating. That is why I suspect the thermal paste deteriorating or the liquid cooling evaporating or leaking.

    I realized that the aluminum case must play a very important role in the cooling and by placing it horizontally on that surface I screwed up the cooling process and something probably went beyond the intended temperature and did not cool down back to its original form.



  • @kev

    Have the issue, it's getting progressively worse, used to think it was just my eyes being blurry but now the entire screen shakes, so I know it's not me. I also get heavy artifacting when watching YouTube and I also believe it to be a thermal issue. Puting my sp4 in the fridge helps, so its definitely a thermal issue. Btw, I don't recommend this method as condensation inside your sp will kill it. My device is unfortunately out of warranty now (purchased 2nd hand 2 years ago, it worked great!) but now I am stuck with a device I can't even use. Purchased it to draw in photoshop but I can't even use it for 5 minutes without the the screen shaking horribly. If you're reading Microsoft, screw you. I will never purchase another surface pro again and I will surely not recommend anyone buy one. (I will show them my unit instead)

    Wishing you all the best of luck



  • @jeffreythe00
    Hallo,
    my Surface 4 is also getting worse day by day (flickering starts 3 years and 4 month after buying..... 😉 of course no computer, tablet, phone should be older than 1 year and a half....customers have to support MS 😉 ).
    I, too, tell everbody NOT to buy these products. If MS have given me an answer to my problem, even if I have to pay some €, I could see this different. So they stole my time (diagnostic tools, setting back, erase all apps, they asked me to send a video, lenght at least xx minutes) and NOTHING ever happened to help me.
    So don't buy a MS computer'!
    Gabriele


 

Looks like your connection to Flickergate Forum was lost, please wait while we try to reconnect.